Over the last couple of weeks we've been working on improvements to browser support for Form submissions and other front-end features that make use of JavaScript.

As such, here's a document explaining our official level of browser support.

To benefit from this new level of support please make sure the following Modules are up to date:

  • System Files -> 2.4.2.0
  • Secure Zones -> 0.9.3
  • eCommerce -> 0.9.6
  • Design System -> 2.1.2
Did this answer your question?